読者です 読者をやめる 読者になる 読者になる

DISTRICT 37

なにか

Ubuntu15.04でpipからmatplotlibが入らない

ということで、リンク先まんまですが

ng3rdstmadgke.hatenablog.com

必要ライブラリをinstallしておく

必要なライブラリはこの3つ

  • libpng-dev
  • libjpeg8-dev
  • libfreetype6-dev

aptを使ってインストールします。

sudo apt install libpng-dev libjpeg8-dev libfreetype6-dev

この後pipでインストールできます

pip install matplotlib

numpy scipy pandas

Python でデータサイエンス

numpy、scikit-lean、pandasの使い方をこのサイトを写経しながら勉強しております。pandasはなんとなくRっぽいですねぇ。Rのggplot2並にmatplotlibが使いやすいと捗りそうな気がしているんですが、、どうなんでしょう?